Angelinux

Piensa libre, piensa Linux

Corregir el error version of the jvm is not suitable for this product en Linux Mint

Corregir el error version of the jvm is not suitable for this product en Linux Mint

Es posible que descarguemos la versión más reciente de Eclipse y al tratar de iniciarla nos muestre el siguiente error version x.y_z of the jvm is not suitable for this product. Version: X.Y or greater is required. Esto ocurre porque en Linux Mint viene predeterminadamente una versión de JDK y al tratar de utilizar la versiónRead more about Corregir el error version of the jvm is not suitable for this product en Linux Mint[…]

Usar un bot de Telegram como monitor de servidores Linux

Usar un bot de Telegram como monitor de servidores Linux

Los bot de telegram están aquí, y con ellos una larga lista y oportunidades que podemos aprovechar para mejorar nuestra productividad, en éste caso para administrar nuestros servidores. Administrar un servidor puede ser una tarea ardua si es que queremos estar pendientes a todo lo que sucede, estar pendiente a los logs, alertas por correoRead more about Usar un bot de Telegram como monitor de servidores Linux[…]

Saber si mi servidor es vulnerable a Dirty Cow y solucionarlo

Saber si mi servidor es vulnerable a Dirty Cow y solucionarlo

La vulnerabilidad registrada como CVE-2016-5195 es un fallo que apareció en el 2007, y permite una escala de privilegios que puede dar como resultado el acceso a root. Aunque no fue catalogada como vulnerabilidad crítica, es importante verificar que nuestros servidores tengan el respectivo parche para proteger a los usuarios y el contenido que tengamos. Primero,Read more about Saber si mi servidor es vulnerable a Dirty Cow y solucionarlo[…]

Elegir una llave privada para comunicar git con el repositorio

Elegir una llave privada para comunicar git con el repositorio

El problema reside cuando utilizamos git en nuestros proyecto, y queremos enviar nuestros cambios a un repositorio, por ejemplo github o bitbucket y tenemos distintas llaves criptográficas en nuestra computadora, siendo que la predeterminada, no está dada de alta en el repositorio. Para ello, podemos agregar una regla de conexión SSH indicando que cuando seRead more about Elegir una llave privada para comunicar git con el repositorio[…]

Convertir un certificado .cer al formato .pem y hacer el envío desde PHP

Convertir un certificado .cer al formato .pem y hacer el envío desde PHP

Cuando en nuestro sistema web necesitamos enviar un certificado digital para demostrar que somos un emisor válido, tenemos normalmente un archivo .cer, el cual no es compatible con el servidor Apache, por lo que debemos convertirlo a un formato compatible, el cual sería .pem. Para realizar la conversión se necesitará openssl, el cual ya viene instaladoRead more about Convertir un certificado .cer al formato .pem y hacer el envío desde PHP[…]